added

pyTenable 1.5.0 Released

Tenable has released pyTenable version 1.5.0.

Added

  • Merged all remaining Tenable Identity Exposure API modules (#466, #468, #484, #487, #496, #497, #498, #499, #500, #501, #503, #505, #507, #509, #510, #511, #516, #517, #519, #522, #525, #526, #527, #528, #529, #531, #537, and #538).
  • Added support for Python 3.12 to the testing framework (#773).
  • Refactored the Audit Log module to support pagination updates (#772).
  • Added Job Adoption support to the Export sub-pkg (#779).
  • Added initial support for the Tenable Attack Path Analysis Findings API (#792).
  • Added Access control to the main IO package.

Fixed

  • Corrected an issue with the TSC Files module (#771).

Removed

  • Removed the v3 Explore sub-pkgs since the API has been deprecated.

Changed

  • Added a deprecation notice to the v3 base sub-pkg. Only applies to access control.
  • Added a deprecation notice to the Target Groups module (deprecated APIs).
  • Added a deprecation notice to the Workbenches module (soon to be deprecated APIs).
  • Added a deprecation notice to the Access Groups module (deprecated APIs).