List asset vulnerabilities

Retrieves a list of the vulnerabilities recorded for a specified asset. By default, this list is sorted by vulnerability count in descending order. The list returned is limited to 5,000. To retrieve more than 5,000 vulnerabilities, use the export-request API.

Note: This endpoint is not intended for large or frequent exports of vulnerability or assets data. If you experience errors, reduce the volume, rate, or concurrency of your requests or narrow your filters. Contact support if you continue to experience errors. Additionally, Tenable recommends the POST /vulns/export endpoint for large or frequent exports of vulnerability data, and the POST /assets/export endpoint for large or frequent exports of assets data.

For information and best practices for retrieving vulnerability and assets data from Tenable.io, see Retrieve Vulnerability Data from Tenable.io and Retrieve Asset Data from Tenable.io.

Requires BASIC [16] user permissions. See Permissions.

Language
Authentication
Header
Click Try It! to start a request and see the response here!